EMnify Cellular Network Outage

Incident Report for ChargeLab

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 16:46 EDT

Investigating

We are currently experiencing an outage with the EMnify cellular network. As a result, EV chargers equipped with EMnify SIM cards may be offline and temporarily unavailable. Our team is monitoring the situation and will provide updates as more information becomes available.
Posted Jun 26, 2026 - 16:27 EDT
This incident affected: ChargeLab Network.